Soundslides Forum

Won't import more than 100 (or less) images

Hi there,
I have just signed up for soundslides. I’m trying to import 240 images but it wont do it. It shows that they are uploading it but in the end there are only 30 images. I tried multiple times and no result.

Can I please get some help?


Hi @alexa.penberthy.

I’m sorry you’re not able to see all of the images you’ve imported.

It could be that your “seconds per image” is set for too long of a duration. When you first import your images, this setting is what controls how many images appear in your slide show (based on the length of your audio file). It’s usually automatically set to make all your images appear, but perhaps it is set to too high a number.

Can you try to adjust it?

I’ve circled the slider in the screenshot below.

A setting of 4 seconds per image is typical in a show.

If that doesn’t fix the issue, I can take a look into your account (with your permission). I’ll need you to email me the show’s URL to and I’ll take a look.


yes, I have done that but because it only imported 30 images it just spaces it out between 30 images.
I’ve tried add more images and again, it picks and chooses what uploads, always skips files. Very time consuming to go check every imported images one by one then add the missing one then slot it in the right order

I’m sorry for the issue, I’ll have to look at the actual show’s data in order to troubleshoot.

Usually changing that slider (and/or refreshing the show’s page) would auto-correct any issue with the timing and image loading.

If you can send me the show’s ID or URL I should be able to track this problem down quickly.


I have added 20 images at the time slowly (even then sometimes it only imported 17 then i had to import again the missing ones). Did that until all 240 images were imported.
The slideshow now is all done, here is the link Soundslides Player but i am hoping this to be fixed so i wont have to do this everysingle time.

Thanks @alexa.penberthy. I’ll investigate from here.

I can see where the image uploads started and stopped erratically. I’ll check with our network provider and track down what was going on.

Thanks for the info.

Yes, absolutely. This experience is definitely out of the ordinary. Sorry again.


Hi Joe,

Just checking if there is any news on this issue? I have just tried to make a new slide and the problem persists.

Thank you

Hey Alexa.

I’ve investigated the issue and I haven’t been able to replicate it here, and I haven’t heard of this issue from any other users. I made a small change in the code last week with the hope that it could provide more error information, but I’m still not seeing an error in the log here at the server level.

I’m totally mystified.

Can you take a screenshot of what the app looks like when you select all of your images (before you click the “Begin upload” button)?

And they take a screenshot when the images fail to import?


Hi Joe,

It doesnt give any errors as such, it simply does not import all images selected. I will try clear all cache or use another browser from my side but in the mean time please find attached a few screen grabs with all the steps exlained as reference. Hope it helps and thank you!

Thanks Alexa!

That helps a lot.

I’ll dig into the issue and post back here, probably tomorrow afternoon (GMT-4, New York timezone).

Just a quick update. I’ve found a situation that will replicate the issue that you’re seeing.

I’m hopeful that this can be fixed early next week. I’ll post another update as the work progresses.

Thanks again Alexa.

Amazing, thanks so much :slight_smile:

I just posted a fix to the server now. You’ll need to refresh the app if it is open in your browser.

If you have a chance, please try uploading those same 240 images and let me know if everything looks ok on your end.

Again, sorry for the issue.


Hi Joe, I just uploaded same 240 images again and all seems to be working perfectly fine now.
Thanks so much for sorting this out!